Powered by md-Blog  文 - 篇  访客 -

MAC OS安装eclipse报错:failed to create the java virtual machine


  分类:插件软件  / 
更新:2020-11-01 17:25:36  /  创建:2020-06-30 13:28:18
不要删除
由于JDK 14, 与现版本不兼容, 导致eclipse 无法启动,
cd 到当前目录下, 对当前JDK 进行删除, 建立对应的目录连接

无需卸载jdk14或编辑eclipse.ini文件。

唯一有用和有效的方法是,修复它:

cd /Library/Java/JavaVirtualMachines/jdk-14.jdk/Contents/MacOS/

然后

sudo rm /Library/Java/JavaVirtualMachines/jdk-14.jdk/Contents/MacOS/libjli.dylib

然后

sudo ln -s /Library/Java/JavaVirtualMachines/jdk-14.jdk/Contents/Home/lib/libjli.dylib libjli.dylib”

不要删除

小站不易,感谢支持!